os/persistentdata/persistentstorage/sqlite3api/TEST/TCL/tcldistribution/unix/tcl.spec
Update contrib.
1 # $Id: tcl.spec,v 1.16.2.15 2006/10/23 17:53:28 dgp Exp $
2 # This file is the basis for a binary Tcl RPM for Linux.
5 %define directory /usr/local
7 Summary: Tcl scripting language development environment
12 Group: Development/Languages
13 Source: http://prdownloads.sourceforge.net/tcl/tcl%{version}-src.tar.gz
14 URL: http://www.tcl.tk/
16 Buildroot: /var/tmp/%{name}%{version}
19 The Tcl (Tool Command Language) provides a powerful platform for
20 creating integration applications that tie together diverse
21 applications, protocols, devices, and frameworks. When paired with
22 the Tk toolkit, Tcl provides the fastest and most powerful way to
23 create GUI applications that run on PCs, Unix, and the Macintosh. Tcl
24 can also be used for a variety of web-related tasks and for creating
25 powerful command languages for applications.
30 ./configure --prefix %{directory} --exec-prefix %{directory}
31 make CFLAGS=$RPM_OPT_FLAGS
34 rm -rf $RPM_BUILD_ROOT
35 make INSTALL_ROOT=$RPM_BUILD_ROOT install
38 rm -rf $RPM_BUILD_ROOT
40 # to create the tcl files list, comment out tk in the install section above,
41 # then run "rpm -bi" then do a find from the build root directory,
42 # and remove the files in specific directories which suffice by themselves,
43 # then to create the files list for tk, uncomment tk, comment out tcl,
44 # then rm -rf $RPM_BUILD_ROOT then rpm --short-circuit -bi then redo a find,
45 # and remove the files in specific directories which suffice by themselves.