os/persistentdata/persistentstorage/sqlite3api/TEST/TCL/tcldistribution/unix/tcl.spec
author sl
Tue, 10 Jun 2014 14:32:02 +0200
changeset 1 260cb5ec6c19
permissions -rw-r--r--
Update contrib.
     1 # $Id: tcl.spec,v 1.16.2.15 2006/10/23 17:53:28 dgp Exp $
     2 # This file is the basis for a binary Tcl RPM for Linux.
     3 
     4 %define version 8.4.15
     5 %define directory /usr/local
     6 
     7 Summary: Tcl scripting language development environment
     8 Name: tcl
     9 Version: %{version}
    10 Release: 1
    11 Copyright: BSD
    12 Group: Development/Languages
    13 Source: http://prdownloads.sourceforge.net/tcl/tcl%{version}-src.tar.gz
    14 URL: http://www.tcl.tk/
    15 Packager: Carina
    16 Buildroot: /var/tmp/%{name}%{version}
    17 
    18 %description
    19 The Tcl (Tool Command Language) provides a powerful platform for
    20 creating integration applications that tie together diverse
    21 applications, protocols, devices, and frameworks.  When paired with
    22 the Tk toolkit, Tcl provides the fastest and most powerful way to
    23 create GUI applications that run on PCs, Unix, and the Macintosh.  Tcl
    24 can also be used for a variety of web-related tasks and for creating
    25 powerful command languages for applications.
    26 
    27 %prep
    28 
    29 %build
    30 ./configure --prefix %{directory} --exec-prefix %{directory}
    31 make CFLAGS=$RPM_OPT_FLAGS
    32 
    33 %install
    34 rm -rf $RPM_BUILD_ROOT
    35 make INSTALL_ROOT=$RPM_BUILD_ROOT install
    36 
    37 %clean
    38 rm -rf $RPM_BUILD_ROOT
    39 
    40 # to create the tcl files list, comment out tk in the install section above,
    41 # then run "rpm -bi" then do a find from the build root directory,
    42 # and remove the files in specific directories which suffice by themselves,
    43 # then to create the files list for tk, uncomment tk, comment out tcl,
    44 # then rm -rf $RPM_BUILD_ROOT then rpm --short-circuit -bi then redo a find,
    45 # and remove the files in specific directories which suffice by themselves.
    46 %files
    47 %defattr(-,root,root)
    48 %{directory}/lib
    49 %{directory}/bin
    50 %{directory}/include
    51 %{directory}/man/man1
    52 %{directory}/man/man3
    53 %{directory}/man/mann